Jump to content
Sign in to follow this  
JayoM

Couple of ailments

Recommended Posts

Couple of problems with the FB. Not *major* right now as the car is in for a bit of body resto. Had the car serviced by a mate, got all the recommended bits and bobs. Car sat up for a couple of days before I took it onto another buddy for the body resto. On the way up to him, the car revved grand but couldn't get it over 40mph? Any ideas? The morning after I dropped it up to my mate, he got the car started. He had the choke the whole way out, left it for about a minute and put it the whole way back in and got out of the car, then it cut out. I usually take it the whole way out, after about half a minute put it half way back in and then once its warm enough put it the whole way back. Anyway, he hasn't been able to get this going again. He can get the dashlights on, but can't get the engine to turn over. The dashlights don't dim or anything when he turns the key to turn it over. The mate who serviced it said it happened to him a couple of times, but he just said there is a bit of play in the barrel. That never happened to me before that. Any ideas on that too? Cheers for any help lads!

Share this post


Link to post
Share on other sites

Re: Couple of ailments

Couple of problems with the FB. Not *major* right now as the car is in for a bit of body resto. Had the car serviced by a mate, got all the recommended bits and bobs. Car sat up for a couple of days before I took it onto another buddy for the body resto. On the way up to him, the car revved grand but couldn't get it over 40mph? Any ideas? The morning after I dropped it up to my mate, he got the car started. He had the choke the whole way out, left it for about a minute and put it the whole way back in and got out of the car, then it cut out. I usually take it the whole way out, after about half a minute put it half way back in and then once its warm enough put it the whole way back. Anyway, he hasn't been able to get this going again. He can get the dashlights on, but can't get the engine to turn over. The dashlights don't dim or anything when he turns the key to turn it over. The mate who serviced it said it happened to him a couple of times, but he just said there is a bit of play in the barrel. That never happened to me before that. Any ideas on that too? Cheers for any help lads!
Hopefully I don't sound like an ass but make sure the battery is fully charged up and in good condition. Cars do weird things when the voltage is too low. You could try taking apart and sanding down the connections of the main battery straps (espesially - to body) and starter motor lead. Without these two there's definately no party.. Hopefully you can get the engine cranking over and then take it from there: check for fuel/spark/compression.. The lack of power thing could be a a blocked carb jet. Dirt or shitty modern petrol can gunk up (if you let it sit) and will restrict your main jet. Best of luck fella :smt023

Share this post


Link to post
Share on other sites

Re: Couple of ailments So, I went out today to decide on the part and have a look at what the problem with it turning over. Turns out my mate who serviced it already went to have a look and sorted whatever it was. I'll have to get onto him and see what he did.! Cheers for the help lads!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×