Jump to content

Recommended Posts

Hey guys. My Rx8 wouldn't go above 4000 this morning and when it did it just dropped back to around 4000 again. I later go a p0302 code. Cylinder 2 misfire. My plugs and coils were replaced last year. I am having trouble with that bloody oil blow back into the air intake though. Had to clean it out twice in two weeks. I changed the oil and filter and the car is only half full with oil. I'm wondering could a bad SSV cause a p0302 code as there is a knocking sound coming from the ssv area of the car that was never there until today. More than a coincidence I'd say. Any help is much appreciated. Cheers

 

Sent from my F5121 using Tapatalk

 

 

Share this post


Link to post
Share on other sites
1. Are the plugs genuine or eBay shite?
2. How’s she starting hot and cold?
3. When was it compression tested and what were the results?
 
 
Had small starting issues but that was sorted by cleaning the MAF sensor. I'm hoping that it's just the ssv. I've read that intake valves can cause misfires which is what it was doing this morning.

Sent from my F5121 using Tapatalk

Share this post


Link to post
Share on other sites

Call me the “feckin harbinger of doom” but last December 2016 to March 2017 I had issues that sound familiar. See my thread on here “won’t rev beyond 3500/4000rpm to see what I finally had. 

As Aidan says, sounds serious. Sorry but it sounds like the engine needs a rebuild. Hope to Christ I’m wrong. 

Go to my thread and do what I did to fault find. Hope it helps and I’m wrong about an engine rebuild. Fingers crossed for you. 

 

Share this post


Link to post
Share on other sites
Call me the “feckin harbinger of doom” but last December 2016 to March 2017 I had issues that sound familiar. See my thread on here “won’t rev beyond 3500/4000rpm to see what I finally had. 
As Aidan says, sounds serious. Sorry but it sounds like the engine needs a rebuild. Hope to Christ I’m wrong. 
Go to my thread and do what I did to fault find. Hope it helps and I’m wrong about an engine rebuild. Fingers crossed for you. 
 
Engine was rebuilt December 2016. I still have to check the plugs. Installed them last March but you never know. Seems like too much of a coincidence though that the knocking sound near the ssv started today and then I get the ECL flashing.

Sent from my F5121 using Tapatalk

Share this post


Link to post
Share on other sites

Well its not uncommon for rebuilders  to reuse side seals and cut-off rings which is absolutely a big no no but from a recent thread here its possible that something like this could have happened you. Have you any paperwork at all to see what new parts were used in the rebuild??


 

Edited by Aido 8

Share this post


Link to post
Share on other sites

Okay I’m gonna tell you right now!

Thats sounds that the same guy who rebuilt my engine in June of 2015 (Leonard). Engine lasted 12,776 miles over  16 months. Paid €2,900 and a waste. 

Get it to Anthony in Shadow Rotary before more damage is done. 

Mine was missing corner seals, wrong e-shaft and apex springs were the wrong ones for the springs. 

Again, check out my thread. 

Share this post


Link to post
Share on other sites
Okay I’m gonna tell you right now!
Thats sounds that the same guy who rebuilt my engine in June of 2015 (Leonard). Engine lasted 12,776 miles over  16 months. Paid €2,900 and a waste. 
Get it to Anthony in Shadow Rotary before more damage is done. 
Mine was missing corner seals, wrong e-shaft and apex springs were the wrong ones for the springs. 
Again, check out my thread. 
Hey, would you you have the number for shadow rotary by any chance. I have an awful feeling that I have a blown coolant seal and a rebuild is most likely.

Sent from my F5121 using Tapatalk

Share this post


Link to post
Share on other sites
Well its not uncommon for rebuilders to reuse  side seals and cut-off rings which is absolutely a big no no but from a recent thread here its possible that something like this could have happened you. Have you any paperwork at all to see what new parts were used in the rebuild??
Hey, looking for a contact number for shadow rotary please if you have one

Sent from my F5121 using Tapatalk

Share this post


Link to post
Share on other sites

Business Name: Shadow Rotary

Location: Unit 1, Windmill View, Blackchurch, Rathcoole, Co. Dublin (N7 Westbound approx. 1.5KM after large Applegreen at Rathcoole)

Contact: Anthony 'Chief Wiggum' @ 085 777 1808 / Dale 'Bradyy' @ 085 146 6188 / Eoin @ 087 450 3938

Description: Rotary engine builds, servicing, porting, rotary compression testing, all things rotary (not bodywork).

Edited by Aido 8

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×