Jump to content
We're Back! Read more... ×

Search the Community

Showing results for tags 'cooling'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to Irish Rotary!
    • Introductions
    • Forum Rules
  • Rotary Vehicles
    • Rotary Engine Maintenance & Rebuild
    • General Rotary
    • RX-7: 3rd Gen FD3S (1991-2002)
    • RX-7: 2nd Gen FC3S (1986-1991)
    • RX-7: 1st Gen SA/FB (1978-1985)
    • Rotary Media
    • RX-8 SE3P (2003-2012)
    • Cosmo and Old-School Rotary (Pre-1978)
  • Traders / Sponsors
    • Campion Insurance
  • Buying & Selling
    • Rotary Cars For Sale
    • Rotary Parts and Accessories
  • Non-Rotary
    • Other Cars
    • Off Topic
    • Forum, Website and Club Suggestions
  • Social Rotary
    • Rotary Meets
    • Was It You ?

Blogs

  • Tutorials
  • Project SRX8
  • BN Sports Blister Kitted RX7 (Daily)
  • FD Street Car
  • An Orange FD
  • rx7 fd 2jz
  • My Rotary Project
  • Kaiju from the land of the rising sun
  • Project Rick Turbo RX8

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests


Location


Biography


Occupation

Found 1 result

  1. Hi everyone, I am totally new to Rotary and have just invested in a mid year 2006 RX8. Perhaps a little the worst for wear, but mostly it appears to be cosmetic at this point. I have just completed an oil and coolant change and both done without a hitch. The car has 158,000kms on the clock but starts within the first second and appears to run very sweetly indeed. When the car arrived (seller delivered it after a 3hr drive) the cooling fans were really at full blast and after engine shut down took about 10mins before silence. This spurred me to change the coolant (as I don't accurately know the history and care I like to start from a clean slate) Tonight (its 0 degrees out there) I took it for a quick drive - 10min drive and after start up 5mins sitting - but upon my return the cooling fans were on and didn't shut off for maybe 5-7 mins after engine off. I can appreciate that this is the car's system for cooling but my question is after such a relatively short journey should the fans be needed to come on? Temperature gauge is indicating that all is well and exactly where it should be so really nothing appears wrong but the car just seems 'hot'. Perhaps the RX8 runs hot? Any 'this is normal' or 'you need to check this or that' would really be helpful. Piston/Cylinder I totally get but Rotary - so interesting! Thanks for your time. Damien.
×