Jump to content

spla300

Registered Users
  • Content count

    76
  • Joined

  • Last visited

  • Days Won

    4

spla300 last won the day on November 18 2017

spla300 had the most liked content!

About spla300

  • Rank
    Junior Member
  • Birthday 07/10/1990

Profile Information

  • Location
    house

Contact Methods

  • Interests
    car
  1. Awesome thanks for thr help. I'll stay out of boost for now. Would anyone have a broken stock ecu for sale Maybe? I need the connector from it so I can connect my ecumaster. Also would anyone have an ignition map please? Once I've that the ecu has an autotune feature for the injector map, I'll just set it to keep it at 10-11 afr and it will adjust the fuelling itself. Sent from my SM-J710MN using Tapatalk
  2. I have a t04z Turbo I just wanna have it running the way she is just to brake in engine for now. I have an ecumaster black edition which I'll wire in at a later date and I'll have to buy injectors. I've yet to buy a walbro pump for it and I'll wire that in directly. As for spring I could even cut a coil off it to reduce it further to maybe 5psi if 8psi might still be too much. I'll also be fitting a wideband into her at a later date. Sent from my SM-J710MN using Tapatalk
  3. Oh yeah cant wait to see what the Clutch feels like without the springs. Also I've got a 12psi spring in the external wastegate I'm guessing that's too much boost for the stock ecu. I wonder if I put an 8psi spring in would the ecu handle the fueling ok? Sent from my SM-J710MN using Tapatalk
  4. Time frame is as soon as I get money together. All i need to get is front mount intercooler now and thats pretty much the engine bay complete she will be driveable. then it's all down to sanding and spraying. Sent from my SM-J710MN using Tapatalk
  5. Sent from my SM-J710MN using Tapatalk
  6. And more... Sent from my SM-J710MN using Tapatalk
  7. Few more pics. Sent from my SM-J710MN using Tapatalk
  8. It's been a while since last update since the forum kept on throwing up some error every time I tried but here are a few photos. Engine is in and brapping away. Sent from my SM-J710MN using Tapatalk
  9. Does anyone use lower temp thermostat? The stock one is 82deg which seems a little high considering engines get pretty hot. There is a 75 and 68deg ones, would 68 be too low? Anyone have some experience with different thermostats? Sent from my SM-J710F using Tapatalk
  10. Do you know what it actually does? Sent from my SM-J710F using Tapatalk
  11. Bottom undersealed. Subframe on and all Aluminium parts sandblastes. Thanks to Lenard for quickly finding me a set of Coilovers. Also can anyone tell me what this thing is on the intake Manifold,? I think one of the pipes from blower was connected to it. Do I need it or can I get rid of it? Sent from my SM-J710F using Tapatalk
  12. Also would these spark plugs do or should I go colder? http://www.ebay.com/itm/271557009702 Sent from my SM-J710F using Tapatalk
  13. Rear half sandblasted and primed gonna move onto front half next week hopefully. Can anyone tell me about injectors? I'm thinking leave primaries stock and get 2000cc for secondaries? Low impedance? Or has anyone got other recommendations? http://www.ebay.com/itm/370743380335 Sent from my SM-J710F using Tapatalk
  14. Pretty big update this time got the Engine assembled, next I'll be working on the Shell. Gonna sandblast the rust, underseal the car hopefully get subframes and running gear back on then spray Engine bay and start fitting Engine in so she can move on her own. Sent from my SM-J710F using Tapatalk
  15. Another little update. I've recieved the stage 4 XTD clutch. Complete kit with light flywheel and counterweight also got the subframes back from sandblasting and galvanizing. Successfully drilled out extra holes in the stationary gear bearings and thanks to Lenard for the rotor bearings, I think I've got everything I need now to assemble the engine. Just need to get bearings pressed in first. Sent from my iPhone using Tapatalk
×